Kindly be advised we cannot cancel subscriptions or issue refunds on the forum.
You may cancel your Bitdefender subscription from Bitdefender Central or by contacting Customer Support at: https://www.bitdefender.com/consumer/support/help/

Thank you for your understanding.

Unable to login to a website using Safepay and some sites don't open automatically in Safepay.

Stargazer
edited January 17 in Privacy

Have only installed Bitdefender since Dec 2023. Have had a few problems logging into some websites - mainly financial or government but solved by going to homepage first rather than using saved login page. But the latest problem I cannot solve. It is an Australian Government website. I can successfully login if not using Safepay. I login using my email address and a password. Even when typing my email address it is underlined in red indicating something is wrong and when I type my password it declines my login. I disable the HIDE so I can check that my password is correct. Have triple checked that I am typing correct login details. But can only login to this site if I do not use Safepay. Have gone through same process several times with same result - OK if do not use Safepay but login declined if I use Safepay.

Another problem I have relating to Safepay is that some sites do not open automatically in Safepay even though when I created the bookmark in Safepay and selected the "open this page in Safepay". So I have to open Safepay first and select the bookmark.

Would appreciate any help with these..

Comments

  • Hello @Stargazer,

    In regard to that gov. website, are you encountering this issue only when trying to login? Are you able to navigate the page otherwise? Bitdefender Safepay also comes with a built-in VPN that secures your confidential data, so if you are using it, it's highly possible that the website is blocking the connection, in this case the login part.

    Since a login is involved, the issue could be related to an additional verification process on their side, where if a secure environment such as Safepay or let's say a VPN encryption is being used, it triggers some warnings on their end and they don't allow the login. This would be my best guess. At the same time, it could have something to do with the actual Safepay browser.

    Concerning the other issue where some sites do not open automatically in Safepay, the secure browser will prompt to open or will automatically open only banking websites, as this is a browser mostly designed for online banking activities. If the websites you are trying to open automatically in Safepay are banking websites, make sure Encrypted web scan option is turned ON. To find it, go to Protection > click on the Settings button in the ONLINE THREAT PREVENTION module, then make sure the ENCRYPTED WEB SCAN slider is set to ON(blue).

    If Encrypted web scan is enabled and you have checked the box to automatically open in Safepay and this doesn't happen, try to apply the repair procedure described here:

    In the event the repair procedure doesn't fix this glitch, I would recommend contacting the Technical Support Teams, as more information might be required to troubleshoot this. You can get in touch with the Bitdefender engineers by choosing one of the contact channels listed here:

    https://www.bitdefender.com/consumer/support/help/

    Scroll down to state your contact reason, then choose from the available contact channels, chat, phone and email/ticket. Chat would be the fastest way to reach them.

    Let us know how it goes.

    Regards,

    Alex

    Premium Security & Bitdefender Endpoint Security Tools user