BitDefender DNS over HTTPS: Internal sites incorrectly resolving with external IP

I've an internal DNS server that resolves basic local domain's before it forwards the resolution for anything that is not on the local domain, to the wider internet via my ISP DNS. DNS Server is, for the sake of this discussion. The domain is, for example something like this:

While BitDefender is installed, internal DNS resolution flip flops between a local IP for a machine with the below DNS entry such as: [ ]

and an external one: [ ] # Example only.

Now that I've uninstalled anything to do with BitDefender ( The app itself + VPN ), it's been about 5 hours and the switching between internal and external resolution has completely stopped. I plan to stay like this wo/ BitDefender for the next few days to see if the issue returns. Another interesting clue is that if I run:


from a command prompt, the correct internal IP is returned. However, when I ping the host, an external IP is shown. I've disabled Chrome DNS over HTTPS (DoH) and did the same for Windows Edge Browser. But no luck. Clearing cache resolves it temporarily before the issue comes back a few minutes later.

The same resolution works on machines that do not have BitDefender running, such as Linux hosts or other Windows hosts. Yet appears not off this one with BitDefender.

Tried searching what this could be coming from but no luck so far.

Would anyone know if there is anything BitDefender does that could be intercepting DNS requests and resolving it against an external DNS? In other words, does BitDefender do anything with DNS resolution in any part of it's code and is there a way to control this behavior via settings?