Safepay pop-up window will not disappear

I have a problem with a Safepay warning in a pop-up window, advising me to use Safepay when making transactions online. The problem is: it will not disappear. I click on "Not for this page" button, on the X at the corner and even on "Open Safepay" button, and the window simply does not go away, even if I click 50 times in a row. Can somebody help me? I am using Windows 10 and the Firefox browser, and the pop-up shows up in the lower right corner everytime I use a bank website. Thanks! Paulo Martins

Best Answers

  • Flexx
    Answer ✓

    Life happens, Coffee helps!

    Show your Attitude, when you reach that Altitude!

    Bitdefender Ultimate Security Plus (user)

  • bcells123
    Answer ✓

    Hi All,

    I asked this question to technical support last night and promptly received the following advice, which solved my particular issue. (I think maybe it is what @Alexandru_BD was referring to about right-clicking the system tray icon).

    It is very simple and I hope it helps you:

    Hello, Thank you for reaching us in regard to this matter.

     It seems like you're encountering an issue where your Bitdefender Safepay settings are not being saved after a system restart, causing the Safepay notifications to re-enable automatically. 

     This could be related to how Bitdefender saves its configuration settings or potentially an issue with permissions on your Windows 10 system.

     Let's try a couple of steps to resolve this issue:

    1.  Run Bitdefender as Administrator: Right-click on the Bitdefender icon and select "Run as administrator" before making the changes. This ensures Bitdefender has the necessary permissions to save your settings changes permanently.
    2. Check for Bitdefender Updates: Ensure that your Bitdefender software is up to date. Sometimes, bugs that affect settings retention can be fixed in software updates.
    3. Reconfigure and Restart: After running Bitdefender as an administrator, go through the steps to disable Safepay notifications again. Then, restart your computer to see if the changes are retained this time



  • garioch7
    garioch7 Defender of the month ✭✭✭✭✭

    @Paulo Martins ,

    Welcome to the Bitdefender Forums. Did you go to the "Privacy" component, click on "Settings," then "Settings" again and toggle off "Safepay notifications?"

    Hope this helps. Have a great day.



    Former Bleeping Computer Malware Response Instructor

  • bcells123
    edited February 21

    I can turn it off as you indicate, but after restarting the computer, the Safepay Notifications toggle has turned itself on again!!! What could be causing this? Windows 10. Thanks

  • Hi @Paulo Martins,

    Alternatively, you could try to run the repair procedure and see if this helps:

    Also try to manually update Bitdefender by right-clicking on the systray icon.



    Premium Security & Bitdefender Endpoint Security Tools user

  • Great, with the comprehensive remedy advised by @Gjoksi it seems to work as I did not get the pop-up window in my banking application again. It also seems to have solved the problem mentioned by @bcells123 of getting the slide buttons back on again, after restarting the computer.

    This of course does not answer the main question, which is: why should anyone willingly encode such a stubborn behaviour in a pop-up window? I imagine that no one did it willingly, so it must be a bug, that maybe can be solved with the Repair Bitdefender procedure that @Alexandru_BD recommended, but which I have not tried yet. I will get back to this thread with the result, once I have done that procedure and checked how it behaves after putting back the notification slide buttons I have taken out now.

    Thanks to all, I never expected such a comprehensive and quick answer to my first question to this forum. It seems to work much better than all the other software fora I have used in the past! All the best!

  • Thank you for following up and for your feedback @Paulo Martins 👍️

    Premium Security & Bitdefender Endpoint Security Tools user