Bitdefender blocking ports on the router

Hello.

I have a Raspberry Pi 5 hosting a Jellyfin Media Server for my personal media content.

It has setup OK on the POi but I cannot access the jellyfin Server from My Windows 11 computers oy my Samsung Galaxy SmartPhones

When tring to make contact with the Pi 5 I am asked to make a connection with the sever, I enter the local IP address of the Pi 5 followed by the Port through which the Pi should be accessed, in the form 192.168.0.4:8086. I have chechrd thr Jellyfin web gui to make sure that both IP and Port are correct. The response on all devices (all running Bitdefender) is that the connection is not available, try again later.

This appears to be a reasonable common problem and, I am told, it is often due to security software blocking the port.

How can I ensure that the port is not blocked by Birdefender as this will take me on step towards solving this problem.

I have worked with computers all my life (I'm 85 years old) but I have had little experience in networking and computer security

Answers

  • Flexx
    Flexx DEFENDER OF THE YEAR 2023 / DEFENDER OF THE MONTH ✭✭✭✭✭ mod
    edited March 22

    Life happens, Coffee helps!

    Show your Attitude, when you reach that Altitude!

    Bitdefender Ultimate Security Plus (user)

  • camarie
    camarie Principal Software Developer BD Staff

    Looks like Firewall is blocking it. I do not now much about how it operates, but I know it creates allow rules for well known programs and I suppose the software is not well known.

    I am forwarding this to the guys knowing more than me so they can pinpoint in the right direction. Probably a custom kind of allow rule based on IP and port should be created, but I would like to know exactly how it should be done. Will get back as soon as I get an answer.

  • camarie
    camarie Principal Software Developer BD Staff

    From the firewall guys:

    Try to add a rule in Firewall on Allow for that local Ip and port: 

    1. Open Security Center->Protection-> Firewall Settings->Rules tab

    2. Select Add rule

    In Add Rule window:

      1. Enable Apply this rule to all applications

      2. Permission Allow 

      3. Network type: Any Network (or Home/Office if he wants to be allowed only on this type of network / his network adapter is set to Home/Office in Network adapters tab in Firewall Settings)

      4. Protocol: Any 

      5. Direction: Both

      6. Select Show Advanced Settings 

      7. Enable Custom Local address

      8. Edit IP

      9. Edit port

     10. Save and check if connection is not blocked 

    I hope this helps.