Does Bitdefender work with MacOS Ventura

Does anyone know if Bitdefender works with the MacOS Venture beta program? If so anyone using Ventura has any issues with Bitdefender working correctly?

Comments

  • Flexx
    Flexx Moderator, Defender of the month mod
    edited July 14

    Bitdefender takes no responsibility to test its product on beta version of an operating system. While you can try it but if something goes wrong with the system, bitdefender will not be responsible for the same.

    Also as per the bitdefender developers, bitdefender products are only developed to be installed on stable version of an operating system. So, it may or may not work on macOS Ventura Preview.

    Regards

    OMEN Laptop 15-en1037AX (Bitdefender Total Security) & Samsung Galaxy S22 Ultra (Bitdefender Mobile Security)

  • As of yet it does not, I have raised it as an issue with apple for their OS development team. I agree that it is not for bitdefender to support but I would assume you want to know about the issue as eventually this should work on venture when it goes GA?

  • Hello,

    It worked with build 3 of the public beta. But since build 4, antivirus updates are in error.

    sorry, the screenshot is with the French version

  • Flexx
    Flexx Moderator, Defender of the month mod

    Kindly wait till stable version of the OS is released.

    Regards

    OMEN Laptop 15-en1037AX (Bitdefender Total Security) & Samsung Galaxy S22 Ultra (Bitdefender Mobile Security)

  • KB71
    edited August 27

    Bitdefender does work with Ventura Beta 4, 5, and 6. However, and it is a big however, there is definitely something wrong...

    It was working fine, but between Ventura Beta 3 and 4, my boot added a 70-second delay, and today I found out that after I uninstalled Bitdefender (it failed to update) when I rebooted, the Desktop came straight up after reboot. It took between 7 and 10 seconds for the Desktop to show up after typing in my password. So Bitdefender adds a significant delay in my boot sequence.

    With Bitdefender, from boot to desktop with a few seconds for entering the password, is 1m:36s.

    Without Bitdefender, 20 seconds.

  • I have noticed several issues when I have Bitdefender installed, and a few people have confirmed similar problems:

    • Bitdefender update no longer works. It reports an error -2, which supposedly means no connection to the internet.
    • With Bitdefender installed, I have incredibly long booting times. With Bitdefender, my Mac Studio will take 100-120 seconds to get from boot to desktop, including a few seconds to type in my password. Without Bitdefender, the same process takes 15-20 seconds.

    Can people with Bitdefender installed on Ventura Beta 6 please confirm if all is working fine, or if these are issues they also are experiencing? So we know if this is unique to a few Macs or general issues...

  • Hi,

    Bitdefender installs OK, but the automatic virus signature updates fail with error -2.

    I have managed to get the definitions/signatures to update once since installing the beta 4 of Ventura, bit other than this issue works fine

  • I'm running macOS Ventura beta 13.0 (22A5331f) and like Kris2179 mentioned, same issue, won't update, gives error -2.

  • Gjoksi
    Gjoksi Defender of the month mod

    Hello.

    -1073741824 or -100, -5, -3, -2

    These update errors appear when a Bitdefender daemon crashes or the update signatures cannot be overwritten. Restarting the Mac should fix the issue.

    If there is any recurrence, reinstall Bitdefender Antivirus for Mac by following the steps from this article. During the installation, the old Bitdefender product is automatically uninstalled.

    Regards.

    Win8.1Pro64bit-TotalSecurity26.0.30.102-Firefox107.0

    Android12-PatchSep1,2022-MobileSecurity3.3.191.2134-Central3.1.10.89

  • @Gjoksi

    Nothing works... I have uninstalled, restarted, reinstalled and still same error and won't update.

    I also got in touch with support staff, they said macOS Ventura is not supported by Bitdefender at this time and told me to downgrade to previous macOS.

    Other than the updates, everything works fine, so I will stick with it as macOS Ventura will come out officially soon and hopefully by then it will work (fingers crossed).

    If anyone gets it working please DM me and also post for others, thanks.

  • With the release of macOS Ventura next week, and possibly available for public download, bitdefender needs to setup and release a working version. The Beta has been out for months, plenty of time to get the code working.

  • Hello,

    On macOS Ventura beta 4 the product update does not work, however, the signature update works. It is unlikely for macOS Ventura to be released in a week, as Apple has not yet announced the official date, but it will probably be around mid-October as far as we know. The update error appeared in the last beta version because of some required changes made by Apple.

    Regards

  • Mat.
    Mat.
    edited September 10

    UPDATE-Fixed

    I have updated my macOS Ventura just now to version 13.0 developer beta 7 (22A5342f) and I'm pleased to say that Bitdefender and the updates are back to normal operation. So make the update and you should be good.

    If anyone is interested in a link to obtain DEV Beta profiles, please DM me.

  • Yeah, it seems the issue was resolved in the new version. Glad to hear this.

    Cheers

  • Agree. Resolved in MacOS Ventura 13.0 developer beta 7 (22A5342f).

  • Anybody else having issues granting BD Full Disk Access? Just installed the new beta 22A5365d but having had these issues since the last version 22A5358e. Cannot open or update BD.

  • Gjoksi
    Gjoksi Defender of the month mod

    @kaYcee

    Hello.

    First, take screenshot(s) of the issue

    and create a log file on your MacOS device using BDProfiler, by following these steps:

    Next, contact Bitdefender Consumer Support by e-mail:

    or

    with short description of the issue.

    After that, you will get an automated reply by the Bitdefender Customer Care Team, with your ticket number.

    Now, in reply to that automated reply, you can send the screenshot(s) you already took and the log file you already created in the first step.

    Since you are all done, just wait for the support engineers to investigate your issue and find a solution to fix the issue.

    Remember that the screenshot(s) and the log file will help a lot to the support engineers for better and faster investigation on your issue and finding a solution.

    Regards.

    Win8.1Pro64bit-TotalSecurity26.0.30.102-Firefox107.0

    Android12-PatchSep1,2022-MobileSecurity3.3.191.2134-Central3.1.10.89

  • Hi @Gjoksi , thanks for the quick response. Since python2 is not shipped anymore with macOS and difficult to install parallel to python3, the BDProfiler ****** cannot be executed. And since BD won't launch, the first option doesn't work as well. But I'm happy to file a request without the log file.

  • After installing the newly released macOS 13.0 (Ventura) (NOT the beta version) I am still getting the "Grant Full Disk Access" screen when I try to open Bit Defender. However, when I follow the instructions on the BitDefender website for doing so, it does not work. It asks me to remove a file that is already not present. Please help.

  • Hello @TMack559,

    Have you followed the instructions from the article below? Try to perform the install from scratch and apply the steps from here:

    Regards