Why Bitdefender so intrusive?


I been with Bitdefender now over 15 years, but I am becoming more and annoyed with the software. For instance, if I am in the process of creating a Youtube video, when I turn on my webcam, it triggers a pop-up in the lower right hand corner. Then I have to close it out. Also, when I use my microphone, a pop is triggered and I have to close out the pop-up. This is super annoying and quite frankly, it pisses me off. I am thinking of not re-subscribing. I don't need Bitdefender to tell me when I'm using my microphone or webcam. And I could never find a way to turn off the pop-ups permanently. Does anyone have a solution? Thank you.

Best Answer

  • Gjoksi
    Answer ✓

    Open your Bitdefender program and go to:

    1. Settings -> General and disable "Special offers" and "Recommendation notifications" (for the "Password Manager" notification)
    2. Protection -> Antivirus -> Settings -> Scan flash drives and select "Autoscan" or "Disabled", do not select "Ask every time" (for the "USB Immunizer Recommendation" notification)
    3. Protection -> Antivirus -> Settings -> Scan CD & DVD and select "Autoscan" or "Disabled", do not select "Ask every time" (for the "CD/DVD Recommendation" notification)
    4. Privacy -> Safepay -> Settings and disable "Safepay notifications" and "Automatically open Bitdefender Safepay"
    5. Privacy -> Video & Audio Protection -> Settings and disable "Notify when allowed applications connect to the webcam", "Notify when an application tries to access the microphone" and "Notify when browsers access the microphone"
    6. Utilities -> Profiles -> Settings and disable "Activate profiles automatically" (for the Profile notification)
      After doing that, in the future no pop-up notifications will be displayed in the lower right corner of your screen.
      REMEMBER: When a threat is detected, a pop-up notification will be displayed in the lower right corner of your screen and you can't disable those pop-up notifications.
      Next, as an option to fully disable the Bitdefender alerts and pop-ups, open your Bitdefender program, go to Utilities -> Profiles -> Settings and enable/activate "Work Profile" or "Game Profile".
      When "Work Profile" or "Game Profile" is enabled/activated, all Bitdefender alerts and pop-ups are disabled.
      Finally, as for the Bitdefender VPN pop-ups, you can simply uninstall Bitdefender VPN from your device by following the steps provided here (just select "Bitdefender VPN"):
      open the Bitdefender VPN program, go to Settings -> Notifications and disable "Allow notifications".
      It is recommended that you also review the privacy preferences set in your Bitdefender Central account:
    7. On any internet-connected device launch a web browser, visit
      and sign in to your Bitdefender Central account.
    8. Click on your username in the top right corner and select "Bitdefender Account" in the menu. This option will launch in a new browser tab.
    9. Access the "Data & Privacy" tab, then click on the "Privacy preferences" section.
    10. Uncheck both boxes to stop promotional messages:
    • Receive in product insights regarding threats, news, and offers.
    • Receive insights regarding threats, news, and offers via email.


  • Alexandru_BD

    Wow @roundball56 15 years with Bitdefender, that's impressive and I take this opportunity to show my appreciation for your loyalty. Here's to many more happy years alongside Bitdefender. 🥂

    I'm sorry to hear you were dissatisfied because of these notifications. The good news is that most of the in-product notifications can be easily disabled, and the ones that cannot be turned off are usually triggered by security events only. You can follow @Gjoksi's detailed guide to disable all unwanted notifications and come back to us to share your future experience.



    Premium Security & Bitdefender Endpoint Security Tools user