Kindly be advised we cannot cancel subscriptions or issue refunds on the forum.
You may cancel your Bitdefender subscription from Bitdefender Central or by contacting Customer Support at:

Thank you for your understanding.

Problem Initializing Gui With Bitdefender Live Rescuecd (Invalid Loop Location: /rescue/livecd.squas

edited February 2022 in The Archive

I am facing a peculiar problem and require help. I was trying to initiate the live RescueCD via a flash drive in my laptop. The problem is, things went fine with the initialisation and then suddenly I would get a prompt of "Ignoring BGRT ..... Invalid loop location: /rescue/livecd.squashfs".

The rescueCD is am using is from here. After downloading the ISO, I flashed it on a SanDisk Ultra 3.0 32GB flash drive using FAT32 file format as referred to here. Then, I ran the drive on my desktop and it worked like a charm but when I inserted the same in my laptop (HP 15-R014TX, preinstalled Win 8.1 currently upgraded to Win 10) it refuses to load the GUI and gives me the error that is attached

Can anyone please get me a way out of this so that I can load it in my laptop as well? Any tweaks that might be needed? And after Bitdefender's Stickifier failed me, I tried Rufus v2.9 as well but in vain. Please advise. If you require any more information or details please ask me. Just so you know, I have tried both by enabling the Legacy boot options and disabling it, nothing worked. Please help!



  • Sorin G.


    Please try to start the LiveCD using the Troubleshooting option. BGRT can be ignored.


  • Hello,

    Please try to start the LiveCD using the Troubleshooting option. BGRT can be ignored.


    Hey, thanks for the up. BGRT was ignored but still I'm getting the same error "Invalid loop location: /rescue/livecd.squashfs".

    The verbose logging ended with lines like:

    >> Initializing root device ...

    >> Determining looptype ...

    !! Invalid loop location: /rescue/livecd.squashfs

    !! Please export LOOP with a valid location

    !! or reboot and pass a proper loop=...

    !! kernel command line

    Busybox v1.20.1 . . . . . . . . etc etc . . . . . and then again stopping right there at the /newroot # as shown in my first post's attachment.

    I previously tried the command "Exit" in this ash shell and the output I got was "squashfs filesystem could not be mounted". Obviously this isn't a normal behaviour. Any help?

  • Sorin G.
    Sorin G.
    edited July 2016


    Please rewrite the Rescue CD by following the steps bellow.

    - I recommend using Rufus (version 2.7 or newer):
    - select the USB stick in the "Device" dropdown
    - check the "Create a bootable disk using" checkbox. From the associated dropdown chose "ISO image". Select the RescueCD ISO image using the button next to it
    - click "Start" (all other options should be left to whatever their default values are)
    - Rufus may ask to download some ISOLinux files, you should allow it to do so
    - IMPORTANT Rufus will show the following dialog:


    - select "Write in DD Image mode" on this dialog