Can`t install Total Security 2017

edited May 2017 in Install activation

I downloaded installation kit from my central account page. Tried to install antivirus, but after  download finishes - Nothing happens. No installation screen or something. Something loaded for around 5 seconds (according to mouse pointer animation).

In Task Manager, i do see "Agent", but not antivirus. When i tried to run installation kit again, i saw "Setup downloader" in task manager. After 1-2 seconds it was closed.

My opinion is that something kills installation process.

I tried to uninstall BitDefender with tools (tried all versions) in Admin account. Also tried to clean registry. No fix yet.

I contacted support team, but none of given solutions helped. Sadly that everything goes slow. 

Windows 10 Home (64Bit)


  • Hi AntoEST,

    What is the current antivirus software you are using?

    Have you tried disabling that prior to the installation process?

    Maybe your current antivirus software is blocking the process.

    Try to update your browser also.

    Cheers! default_happy.png