New Bitdefender Blocking Blizzard Products


Just wanted to note, I updated to Total Security 2019 yesterday, I manually ran "Update" like 5 or six times, computers been through multiple reboots.


This morning Blizzard Entertainment released a update hotfix for World of Warcraft, I kept getting stuck at 'Fetching download manifest' - the first step of the download, it got past that a few times and proceeded to have a spotty download only ever getting up to 4 bytes per second maximum.


After about 4 hours worth of troubleshooting, trying to open and re-open ports, allowing all blizzard related including blizzard launcher application access through the bitdefender ts 2019 firewall, Nothing At All Worked At All.


 


Bitdefender 2019 is Completely Incompatible with the Blizzard Launcher and appears to be blocking all ports related to blizzard and blizzard games, likely including Destiny 2.


 


Just thought I would tell you this, Blizzard knows this now because I worked with them on their forums, so maybe they will contact your developers, or maybe they won't, I don't know if you guys collaborate with big software developers.

Tagged:

Comments

  • edited September 2018


    Oh, didn't mention too that At one point I completely uninstalled the Blizzard App (their downloader/drm), tried to reinstall it with Bitdefender 2019 still active, and it would cause that download to also fail and crash asking me to "Check my Internet Connection".


    I fixed everything by uninstalling bitdefender and reverting to the built in windows 10 antivirus, all downloads went through like normal.


  • Hello, 


     


    Thank you for the report. Our development team is aware of this issue. 


  • Hi,


     


    Rainbow Six Siege is also compoletely blocked.


    I am only able to connect me to the UBI Servers by UNINSTALLING!! Bitdefender o.O


     


    Regards


  • Has this been fixed yet? because im still having serious problems with blizzard stuff.


    Reinstalling the blizzard launcher right now, im stuck at 1%  for 20 minutes now, being installed to my primary drive SSD with plenty of space open.


    Last week, Destiny 2 was also downloading at like 1 bit per second, I was forced to download it and transfer it to my pc from a school pc.



  • 17 minutes ago, Daethz said:



    Has this been fixed yet? because im still having serious problems with blizzard stuff.



    It hasn't. I just uninstalled bitdefender rebooted and now the blizzard launcher is installing and download quickly with no issues.


  • Hello the solution of adding exceptions on Threat Prevention doesn't work for me. Any news for a solution, it's getting a long time.


    Thank you in advance.


     


  • "Exceptions" is also not working for me.  I have posted in a couple likely related threads seemingly related to SSL:


     

    /index.php?/topic/79753-bitdefender-2019-stopping-all-https-secure-sites-access/&do=embed" style="height:339px;max-width:502px;">/index.php?/topic/79902-bitdefender-2019-blocks-my-smart-card-from-web-browsers/&do=embed" style="height:219px;max-width:502px;">


     


  • Would like an update on this issue please.  The only fix I have found so far is to completely uninstall BitDefender.  Even disabling protection temporarily doesn't work.


    I'm about to hit renewal and wondering if it's time to start exploring alternatives.


  • /index.php?/profile/215338-nate/&do=hovercard" data-mentionid="215338" href="<___base_url___>/index.php?/profile/215338-nate/" rel="">@Nate


    Please send us an email at [email protected] so that we can try and find a workaround for you. It's possible that with different exceptions the app could work, until a permanent fix is released. 



    Thank you!


  • Hi, this issue comes up every through months and never seems to get fixed. There was a previous post from September with the same title as this that raised the issue (I can't link it as the post gets blocked)    Like the previous poster updates of Warcraft no longer work.


    So, Bitdefender gets updated to 2019 and then Blizzard puts out a big update of Warcraft and it looks like Bitdefender blocks it with no notifications.  The previous post linked has gone to development, any news on this?  Could Bitdefender reach out to Blizzard and sort this out once an for all?


    Adding the Blizzard exes to the Firewall makes no difference, adding the URLs mentioned in the previous post to exceptions under Online Threat Prevention makes no difference.


    Perhaps there are new URLs for the new patch?  I've raised this question on the Blizzard technical support forums as well.


    I like Bitdefender and I do not want to stop using it, but there is only one Warcraft so if necessary I would have to change AV supplier which would be a shame.


    Any suggestions gratefully accepted.


    Thanks


     


  • Found a workable workaround.  Booted up in Safe Mode with Networking and the update proceeded under this.  Not ideal, but at least I didn't have to uninstall Bitdefender.


    Hopefully this issue will get a proper fix one day.

  • edited January 2019


    This is strange. I bought BitDefender two weeks ago and installed it on my iMac Bootcamp partition (in Windows) and had no issues.


    Today, my new PC arrived. No issues with updates but it literally would not load World of Warcraft. It would sit in my Task manager and download like crazy but not open. I disabled features one at a time.... nothing worked until I uninstalled it.


     


    EDIT: Fixed it but I literally had to go through every setting and add exceptions for wow.exe, wow launcher, battlenet and battlenet launcher. 



  • On 11/8/2018 at 7:18 AM, Sergiu C. said:



    /index.php?/profile/215338-nate/&do=hovercard" data-mentionid="215338" href="<___base_url___>/index.php?/profile/215338-nate/" rel="">@Nate


    Please send us an email at [email protected] so that we can try and find a workaround for you. It's possible that with different exceptions the app could work, until a permanent fix is released. 



    Thank you!



    It would be nice if you could post your workarounds so we could all try to use the workarounds

Sign In or Register to comment.