Windows 10 - Virtual Hotspot blocked?

I'm using the trial version of BD and ExpressVPN on a Windows 10 PC and I'm using a Netgear A7000 mobile wifi adapter. The hotspot had worked fine until installing BD. Uninstalled BD and Hotspot works fine. Did this a few times. I don't understand much of this but I'm guessing from what I've read that the BD firewall is preventing this virtual hotspot connection. Not sure what to change and were. I get a message "Couldn't get IP address" on my mobile devices.
Thanks for any help.

Comments

  • Well I have a thread about this very problem, from a few years back. At the time I was using BitDefender Total Security 2019. However I'm now using the 2020 version and the issue and solution was the same as it was back then.

    What is needed is a Firewall exception for the 192.168.137.1 DHCP server, which is what Win10 hotspot uses. All devices connecting to the laptop's enabled hotspot will get a 192.168.137.x IP address assigned.

    AT the time of 2019, that's all I had to do. And I was now able to connect from the phone, Roku, etc., and get an IP address.

    [img]https://imagizer.imageshack.com/img924/9169/sOnXi2.jpg[/img]

    [img]https://imagizer.imageshack.com/img923/9692/TiB8jq.jpg[/img]

    [img]https://imagizer.imageshack.com/img924/2710/OJbpBQ.jpg[/img]
  • Unfortunately, I am now using the new version BitDefender 2020 , Build 25.0.26.89 dated 9/18/2021. So very latest. And Win10 21H1 on my laptop.

    And I am disappointed to say that even after creating the exact same required Firewall rule which still does allow the connection to be made from the phone, with a 192.168.137.x IP address assigned, BitDefender now adds an addition insurmountable obstruction to Win10 hotspot working properly: CONNECTED WITHOUT INTERNET.

    I have duplicated the "connected without internet" failure using my Roku Ultra, configuring a wireless connection to the Win10 hotspot on the laptop which again is running BD 2020 with the firewall exception rule in place. Roku says the connection is just fine (green check), but internet access is missing (red X).

    I have tried totally disabling Firewall in BitDefender, but this doesn't change anything. The connection and IP assignment was already successful due to the proper Firewall rule I'd added. So clearly, there must be something else in BD 2020 25.0.26.89 which is responsible for not allowing actual access to the internet for both connected devices.

    I don't know what other kind of exception rule or item might be added in any of the other of the major functional areas of BD, which might be controlling "internet access", but obviously I need to get someone from BitDefender tech support to answer that question.

    And, not at all surprisingly, all i have to do is totally uninstall the BitDefender product, and sure enough now Win10 hotspot works perfectly, using the very same Samsung S21 Ultra phone and Roku Ultra 2020. Both devices now connect, get a 192.168.137.x IP address assigned, and HAVE FULL ACCESS TO THE INTERNET!!!

    Therefore it is undeniable and 100% the fault of BitDefender 2020 that Win10 hotspot does not work on my laptop. Install the product with proper Firewall for 192.168.137.1, and IP gets assigned but "connected without internet". Uninstall the product and everything "works perfectly".

    I request someone from BitDefender to pitch in here, and provide assistance. What else is needed to be done in order for BD to allow Win10 hotspot to work as Microsoft intended, rather than breaking it?
  • I just solved this issue by selectively allowing all connections svchost on my private LAN created by my hotspot. I did this by setting the Hotspot adapter as Home/Office. This prevents anybody from outside to get access to svchost but only devices connected to my hotspot to get the IP configuration.

    Restart PC and client devices (smartphone) and attempt to connect. Let me know if this worked.

  • I just solved this issue by selectively allowing all connections svchost on my private LAN created by my hotspot. I did this by setting the Hotspot adapter as Home/Office. This prevents anybody from outside to get access to svchost but only devices connected to my hotspot to get the IP configuration.

    Restart PC and client devices (smartphone) and attempt to connect. Let me know if this worked.

  • Kindly ignore the duplicate posts above

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.