Bitdefender Total Security Firewall off interferes with updates

If Bitdefender's firewall is turned off updates fail with error code 1004. No proxies on my system. Win11. Firewall on updates work fine.

Supper annoying with the above, as I am running WSL and have to turn Bitdefender's firewall off to use my terminal. Support has been going in circles on this one. Anyone have a solution?

Tagged:

Comments

  • Flexx
    Flexx DEFENDER OF THE YEAR 2023 / DEFENDER OF THE MONTH ✭✭✭✭✭ mod

    Life happens, Coffee helps!

    Bitdefender Ultimate Security Plus (user)

  • Hello @hcksharp,

    According to the latest reply from the Support teams, try to update Bitdefender to the latest version and check if the behavior has been corrected. You can find the manual update guide here:

    Bitdefender’s most recent version number is 27.0.27.130 and was released on February 5, 2024. This should normally fix the situation.

    Regards,

    Alex

    Premium Security & Bitdefender Endpoint Security Tools user

  • Thanks for the replies.

    So far I have done repair install, uninstall and reinstall -> issues persists.

    Updated to 27.0.27.130 with firewall enabled -> successful.

    Still if I follow this with an update with the firewall disabled I get 100% updated. However looking in the logs "Update encountered an error (error code: -1004). Bitdefender could not connect to proxy or update server configured. Please check your internet connection and try again"

    In addition even with build 27.0.27.130 I have to turn off Bitdefender Firewall to use WSL and Linux terminal for my development as I can't access such simple things as sudo apt update with it enabled.

  • Hello @hcksharp,

    The error code -1004 indicates that you are connected to a proxy but didn’t activate proxy usage in Bitdefender, so it can use this type of connection. 

    If you connect to the internet via proxy

    • Open Bitdefender, go to “Settings” > “Advanced” > enable “Proxy server”. Bitdefender will import your proxy settings from the default browser. 
    • If custom proxy settings are required, while still in the “Advanced” tab from Bitdefender “Settings”: click “Proxy Change” > select “Custom proxy settings” then fill in the required information.

    If you don’t have a proxy connection

    • Open Bitdefender, go to “Settings” > “Advanced”, and make sure “Proxy server” is turned OFF.
    • If the error persists, follow these steps to remove any proxy settings.

    Let us know how it goes.

    Regards,

    Alex

    Premium Security & Bitdefender Endpoint Security Tools user

  • @Alexandru_BD thanks, but like I have said it's going in circles. Did all the proxy steps, not on a proxy. Frustrating, as it used to work, but an update within the last two month or so changed that. I have to manually update with firewall enabled, as automatic updates have not worked for the last 4 or so days either.