Kindly be advised we cannot cancel subscriptions or issue refunds on the forum.
You may cancel your Bitdefender subscription from Bitdefender Central or by contacting Customer Support at: https://www.bitdefender.com/consumer/support/help/

Thank you for your understanding.

Problems with device locator

Options
Firecapt
Firecapt ✭✭✭

Device locator (laptop) seems to be unreliable. One time it shows the device as being at one location, and the very next time it shows the device as being somewhere else.

Has anyone had any experience with this feature, and can you offer some advice/guidance on what can be done to pin down the actual location of the device?

Thanks!

Comments

  • Alexandru_BD
    Options

    Hello @Firecapt and welcome back to the community.

    Ok, so first the device must be connected to the Internet to receive this command. Make sure you have a stable network connection.

    I presume your laptop does have a wireless network adapter, correct? If it doesn't, then the location is determined based only on the IP address, which is considerably less accurate. Try to reconnect the device you want to locate via Wi-Fi, then try to locate it again with Bitdefender Anti-Theft. If the location is still inaccurate, do the following:

    Clear your browser's cache and cookies: hold down at the same time Ctrl+Shift+Delete keys. Select Cookies and Cache (Temporary Internet Files in IE) checkboxes then click Clear/Delete button. Login again to Central and try to locate the device.

    If this doesn't do the trick, check for any other security solutions and firewall programs and uninstall them, if any.

    Restart Windows and check if the issue is resolved. In the event the device still can't be accurately located, turn OFF Bitdefender Firewall and check again.

    If it doesn't, Turn ON Bitdefender Firewall and :

    1. Go to Network Adapters tab and set the network type to Home/Office using the drop-down menu near its name

    2. Then, from the same Firewall Tab, click on Settings from the top-right , then, for the network you're currently connected to, uncheck the stealth mode button to disable it.

    That's all I can think of right now.. In the event the device location is still incorrect, I would recommend to contact the Support teams for a more in-depth investigation, as more information might be required to troubleshoot this. You can get in touch with the Bitdefender engineers by choosing one of the contact channels listed here:

    https://www.bitdefender.com/consumer/support/help/

    State your contact reason, then choose from the available contact channels, chat, phone and email/ticket. Chat would be the fastest way to reach them.

    Let us know what worked for you.

    Regards,

    Alex

    Premium Security & Bitdefender Endpoint Security Tools user

  • Dennis T
    Options

    I searched for two of my devices connected through the same router via WIFI and one is correct while the other is not. That's troubling for a feature that should be capable of locating a device and wiping it clean. Both devices are next to me and the incorrect computer is a Win 11 box that I used to issue the locate command. The reported IP is correct for both and the Win 11 unit is identified as Win 10. I'm new to Bit Defender - been using Norton for many years before it became so spammy. Hopefully, I'll find what is causing the problem but the find device feature is scary as it stands.

  • Alexandru_BD
    Options

    Hi @Dennis T and welcome to the Community.

    Have you followed the steps from my previous comment, as you didn't mention this? If yes and they didn't make any difference, I would recommend contacting the Support teams for further assistance. You can find the contact details in my comment above.

    Regards,

    Alex

    Premium Security & Bitdefender Endpoint Security Tools user