[Fixed] Bitdefender Total Security 2017 Firewall Adapters Missing

edited March 2017 in Protection


I have been running Bitdefender Total Security (BTS) since the 2008 version.  Within the past 3 months, we upgraded to the 2017 version.  This past week, I have had multiple PC's running BTS 2017 exhibit the same problem.  All PC's in question are running 64-bit Windows 7 Professional Service Pack 1.  The problem surfaces to the end user by blocking network connectivity.  Digging into BTS Firewall settings, there is no Adapter listed.  Also, since there is no Adapter listed, there is also no Network Exceptions available.  Turning off the BTS Firewall resolves the issue.  Yesterday I have used the BTS Uninstall Utility to completely remove BTS from the affected system then reinstalled BTS 2017.  Today another PC is exhibiting the same issue.  Is this malware that I'm dealing with or some buggy BTS issue?  How can I resolve this issue and get back to a stable operating environment?


----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


 



On 3/14/2017 at 10:48 PM, Sorin G. said:



The situation reported in this thread is known and it is being worked on. We deeply apologize for the inconvenience.


At this time there is no ETA. As soon as there are news regarding this issue, the thread will be updated.


There are three ways you can workaround this issue.


1. Disable the Firewall and activate the Windows Firewall


- Rest assured that the other modules are fully active and will keep the machine protected


- Bitdefender > Protection > View Modules > Firewall - The ON/OFF switch is at the top right corner of the interface


2. Revert to the previous build


- Run a repair on he product - https://www.bitdefender.com/support/how-to-repair-bitdefender-2017-1737.html


- Afterwards change the updates to "Prompt before downloading"  - Bitdefender > Settings > Update


- Once the product will want to Update, please make sure to select onl ythe Virus Signatures and not the Product Update.


- Please note that this will disable the AutoPilot, enabling it will undo the Update settings.


Update.PNG


3. If the product is blocking certain Shares/Wireless Printers you can add a exclusion on their local IP (this one is more situational)


https://www.bitdefender.com/support/how-to-add-a-network-exception-in-bitdefender-2017-(i-cannot-access-a-device-on-my-network)-1792.html


- Alternatively you can add the whole local network 192.168.0.1/24 | 192.168.1.1/24


NOTE : Since the Adapters are not available please add the IP Exclusion on all Profiles (Trusted/Home-Office/Public/Untrusted)


exclusions.PNG


Thank you for your patience.



 

«13456

Comments


  • I have the same problem too, my VPN connection doesn't show in Network adapters list.


    I'm using Bitdefender Internet Security 2017, my OS is Windows 7 Professional Services Pack 1 x64.

    bitdefender report.png


  • Same problem here!


    Also Windows 7 Professional Service Pack 1 x64 and Bitdefender Internet Security 2017.


    Connections to network drives (SMB) are blocked by the Bitdefender Firewall. If the Firewall is turned off, it works. The machine is connected via VPN (Cisco Any Connect).


    I wanted to check the Network Type for the Adapters in the Firewall Settings and set them to Home/Office to fix the issue. But i have the same issue as MHCadmin, at least if i understood correctly.


    In the Bitdefender Firewall Settings the list of Network Adapters is EMPTY. There should be a Wireless Connection, there should be the VPN Adapter, but nonthing at all. Windows Network Settings shows them, Bitdefender doesnt.


    This seems to be a Bitdefender Issue! 


  • I have the same problem. BitDefender Total Security 2017, Window 10.


  • Same issue: Adapter list is completely empty.


    Running Bitdefender Total Security 2017 Build 21.0.24.53, WIN 7


  • Same issue: Adapter list empty, therefore unable to make adjustments. Firewall blocks my VPN (Open VPN). Turn off firewall, VPN works.


    Bitdefender Internet Security 2017 21.0.23.1101. Windows 7


     


  • Same issue: Adapter list emtpy. I cannot access network drives. Turn off firewall and problem is gone.


    Bitdefener Total Security 2017 Build 21.0.24.53, WIN 7 Professional Service Pack 1


  • Hello,


     


    Please run a update from the Bitdefender interface and reboot the machine afterwards.


    Let me know if the issue persists.


  • Hello Sorin,


    Thanks for your help.


    Updating fixed the missing adapter issue for me, but not for my colleague running the same environment basically... very strange.


    Also, for me still one issue remain. Now that I have the adapter back, I added the network exception for my network printer. However each time I restart the exception is gone again... And therefore cannot access the printer. 



  • 44 minutes ago, Sorin G. said:



    Hello,


     


    Please run a update from the Bitdefender interface and reboot the machine afterwards.


    Let me know if the issue persists.



    Updated and rebooted twice but the network adapter list in the firewall settings is still empty (Bitdefender Internet Security 2017 Build 21.0.24.53).


    I had a look at my firewall settings in %PROGRAMFILES%\Bitdefender\Bitdefender 2017\settings\firewall


    - ig_profiles.xml - Has almost 1000 lines, which are almost 100 profiles. The machine is rather new and was connected to one LAN, two WLAN, one VPN, no Bluetooth...


    - ig_zones.xml - Basically empty


  • Hello,


     


    Please contact our support team via [email protected] with the logs from the Bitdefender Support Tool to be able to investigate this issue.


    https://www.bitdefender.com/support/How-to-generate-a-support-log--1168.html



  • 14 minutes ago, Sorin G. said:



    Hello,


     


    Please contact our support team via [email protected] with the logs from the Bitdefender Support Tool to be able to investigate this issue.


    https://www.bitdefender.com/support/How-to-generate-a-support-log--1168.html



    Hi Sorin,


    done.


    Two days ago i also submitted a report directly from the bitdefender app. Now i have send the generated zip file to [email protected]


  • Hello,


     


    Thank you for providing us with the requested information.


    Please also provide me with the ticket number generated after sending the logs.


  • Update/restart did not fix it. No adapters when I connect to my iPhone WiFi hotspot. When I am home connected to my home WiFi, then the adapter shows up. Submitted a support request through the Bitdefender interface. No ticket number was given.


  • I've been following this topic and all the posts in it and I have today, I'm still having an issue.  Today I ran the repair option on two PC's.  It works initially, but subsequent reboots later the network exceptions I've added now countless times are still missing.  Something is buggy here for sure!  My missing adapter appears to have been resolved with the repair and/or reinstall, but I can't get my network exceptions to stick after reboot.  I have submitted a ticket (#2017030716430005) and several log files already via the automated trouble support tool within BTS, however, the back and forth process with tech support is so painfully slow and meanwhile I'm left with limited network access and frustrated end users who need this to work as it is supposed to work.

  • edited March 2017


    Same here.


    Adapter field is EMPTY.


    I am not able to exlude an IP. Yes sure i can, but after a restart it is EMPTY again. It is a bug. My girlfriend from Brazil, that uses BD Total Security 2017 has this prob, too.


    My Dad, that uses same Version, has this prob, too.


    I have this prob.


    It is a bug inside the software, once again. Ah and before i forget: The search advisor inside firefox 52 seems to stop too. The certificate inside Fox from BD seems corrupted. Hope u guys solve this heavy bug as soon as possible. And for this all i reinstalled Windows 3 times! Facepalm. I thought that my adapter is defect...


     


    I use Windows 10 Professional 64bit


    My girlfriend uses Windows 10 Professional 64bit


    My dad uses Windows 10 Home 64bit.


    We all use the latest version of Bitdefendet Total Security 2017.


    Friendly greets from Germany.


    B)


    PS: cant we put this into one topic? We have few topics open bout this problem. Peace and cheers.


  • I repaired my Bitdefender and it seemingly fixed the empty adapter list: https://www.bitdefender.com/support/how-to-repair-bitdefender-2017-1737.html

  • edited March 2017


    @THX


    thanks buddy i will check it out, tho.


     


    cheers.


    "Aunt Edith" tells me that:


    Nope after some restarts the prob is back again. sad, sad sad....


  • After running the repair and rebooting, the adapter shows up, but then after running the update and rebooting, the adapter is gone again.


  • Yepp Brent. Thats what i mean.



  • 3 hours ago, THX1138 said:



    I repaired my Bitdefender and it seemingly fixed the empty adapter list: https://www.bitdefender.com/support/how-to-repair-bitdefender-2017-1737.html



    I was experiencing the same problem with the network adapter not showing up and this article was very helpful.

  • edited March 2017


    I am experiencing the same problem with an empty adapterlist, and a brother printer not accessable as usual. Need to get the BD firewall down first, then the printer is online again and works as usual.


    I also noticed that shutting down Windows 10 (64b) takes a lot longer and starting up too. On my i7 Asus ZenBook I am used to shutdown and startup times in the range of 10 .. 15 sec, but now it takes a minute and startup is sometime problematic: I have to do it several times, I see sometimes only the mouse pointer! 


    I also 'repaired' Bitdefender as [email protected] and THX1138 suggested, but then the Repair is only working up to the next update that comes in a matter of minutes and then the problem is back. So I conclude that the latest update is the problem: it messes things up! 


    How can we skip this update of Bitdefender?


  • I have it working now, although I suspect only temporarily. I ran repair again and then update while attached to my home wifi. Both my wireless and wired adapters are showing now in the firewall tab and I can access my network storage, which I could not when the adapters were not showing without turning the firewall off. The wifi advisor though, shows no adapters which is strange even though I am connected to my home wifi. I suspect when I go to work tomorrow and connect to my iPhone hotspot, the adapters will disappear again and my vpn will not work without turning the firewall off. I may have to pursue going back to 2016 Bitdefender which worked fine.


  • Same story here. I missed all adapters, tried to repair as it suggested, but it crashed my Windows 7 SP1.


    After safe mode uninstall, clean install I could see my adapters, but after update its missing again.


    I can not access Windows shared drives thru OpenVPN, nor my printers in local network (IP port connected).


    I can access printer admin console via HTTP and even scan, but whatever Windows use for printing does not pass firewall at this moment and Windows see the printer as offline. When I turn off firewall, starts printing immediately


    Please fix it as soon as possible. I have no access to my files nor my printers. The only way to work is with the firewall disabled.


    Bitdefender build 21.0.24.53


  • Same issue for me with bitdefender total security 2017 and win 10 since the last update...


  • Hello,


     


    Thank you for all of your reports.


    Our devs are currently working on a fix for this issue.


    The fix will be deployed via automatic updates.


  • Thanks Sorin G. for the feedback!


    So the guys are working for a solution. And good that an admin is following this forum. To inform the programmers bout that bug.


    Anyways thanks and a nice weekend to all here. The more people went into this forum for finding a solution, the more it "escalated" - had a good thing, tho.


    Cheers.


  • After performing an BTS update today, I see this new adapter listed in my Firewall, Adapter settings page that I've never seen before.  What is this and why is it showing up here now?

    BTS Adapter.jpg

  • edited March 2017


    Deaktivieren von Isatap, Teredo, 6to4


    Open CMD as ADMIN. Then copy and paste the lines.


    netsh interface ipv6 6to4 set state disabled default

    netsh interface ipv6 isatap set state disabled

    netsh interface ipv6 set teredo disabled


     


    Especially command "netsh interface ipv6 set teredo disabled" should be interesting for you! Cheers.


    this.png


  • I have the same issue, also did Repair option but it helped only till software uploaded update :(


    It drives me crazy, especially that i took mi couple hours to understand what is the problem...

  • edited March 2017


    @nadol just leave it as it is. As long nothing serious happens, its ok. Wait the next few days for an update and do NOT reinstall windows again....or BD 2017....


    just leave it as it is or use the win firewall combined with the antivir from BD 2017. And turn the BD firewall off.


    i just leave it as it is for now and wait for the update.


    cheers.

This discussion has been closed.