Does BitDefender prevent Win10 Mobile Hotspot client connections?


I don't know if BitDefender is involved at all, but I'll ask the question anyway.


I'm trying to get Win10 Mobile Hotspot to work, using  Lenovo P70 laptop which is ethernet cable connected to a router/modem/internet.  I want to share its wired ethernet connection, via the Win10 Mobile Hotspot functionality, so that nearby devices (phones, other laptops, etc.) can connect via WiFi to the P70, sharing the P70's wired ethernet connection to the internet.  Same concept as using mobile hotspot functionality on a smart phone, to provide internet via Wifi (to the phone's hotspot functionality) to nearby laptops, tablets., etc.


Everything is set up and configured to work, and it all looks like it's correct. Except that the nearby client phone and laptop do not successfully connect to the P70's Mobile Hotspot SSID.  The phone fails to be given an IP address, and the laptop connects (ending up with a bizarre IP) but "no internet access" (no doubt because the IP address is garbage).


The issue may be elsewhere, but I'm just asking here if anybody who's running BitDefender has ever successfully implemented this Win10 Mobile Hotspot functionality, and had client phones and laptops successfully connect via WiFi to the Mobile Hotspot running on the PC running BitDefender.  If so, did you have to do anything special in BitDefender to facilitate the success? Firewall exceptions? Anything?


 


 

Comments


  • Hello /index.php?/profile/216340-dsperber/&do=hovercard" data-mentionid="216340" href="<___base_url___>/index.php?/profile/216340-dsperber/" style="" rel="">@DSperber,


    In this case my advice is to apply the recommended settings for the firewall:


    - Open Bitdefender 2019

    - Click on the Protection menu item

    - Click on the gear marked 'Settings' icon under Firewall

    - Select the Network Adapters tab

    - Make sure that Home/Office is set next to the names of your network adapters

    - Select the Settings tab and click on Edit stealth settings, and turn off this feature for your network adapters.


    - Check if the situation persists afterwards.

  • DSperberDSperber
    edited November 2019


    Turns out your answer is off the mark.  Through my continued experimenting today I discovered that (a) indeed it WAS BitDefender Firewall which was responsible the failure of Win10 Mobile Hotspot to function properly, and (b) the solution was to create a firewall exception rule for local IP address 192.168.137.1 which is the static IP address assigned by Win10 when you turn-on Mobile Hotspot.  That is ALL that needs to be done, nothing else, and now the Mobile Hotspot functionality works perfectly.


    In other words BitDefender Firewall IS doing what it is supposed to do, namely to protect arbitrary client devices from connecting to my "defended" PC's WiFi Hotspot without my knowledge or authorization.  Unfortunately, this type of connection requires DHCP (from the hotspot default gateway, i.w. IP 192.168.137.1) because devices like phones and laptops depend on being assigned an IP dynamically when connecting to a "hotspot", rather than connecting through a manually assigned static IP address.  That means  BitDefender can really do all-or-nothing.  Either it PREVENTS/BLOCKS ALL external devices from making use of Hotspot, or it ALLOWS ALL external devices to connect.


    And by default, it is BLOCKING ALL connections to the hotspot.  With a properly coded firewall exception rule, it now ALLOWS connections to the hotspot.


    So, after adding the following firewall exception rule the problem was 100% solved. Mobile Hotspot now works perfectly, and both my phone and second laptop are now connected through the hotspot provided by the primary laptop which is ethernet cable-connected to the router/internet.


     


     


    BD_2-settings.jpg


    BD_3-advanced.jpg

    Success_ethernet-status-details.jpg

    Success_hotspot-status-details.jpg

    Success_network-connections.jpg


  • Hello,


    I'm glad to hear you got this solved! Also, thanks for posting your solution, this will certainly help other members of the community!


    Thread locked.

This discussion has been closed.