Bitdefender Wallet no longer in Firefox browser

Hi I have all my passwords stored in Bitdefender Wallet. I have Bitdefender Total Security 2020. The wallet addon is no longer in Firefox. How can this be restored? Any information would be appreciated.


  • Same, here!

    The extension is gone in Firefox and even worse, the complete wallet is gone from the Security Center. BDSupport recommended to create a new wallet.. - wtf???

  • Bughunter47
    edited May 2020

    You are correct that the Bitdefender Wallet Extension is no longer compatible with Firefox (normal and developer versions); That being said, this is not the end of the world, your wallet is tied to your Bitdefender account and is multi browser and multi computer too. On any compatible platform that has (in your case like me) Total Security 2020 can be accessed from here; it also compatible with Chrome.

  • Flexx
    Flexx Defender of the month mod
    edited May 2020

    HI @trainerj59

    As per the Bitdefender support website , the wallet is still available for Mozilla Firefox. If it would have not been then it would have been updated on the Bitdefender support website :

    Secondly you should try this step and see if it works (firefox support) :

    Nevertheless, if it does not works, kindly create a support ticket with Bitdefender support, since it might be a bug issue with the product : or drop an email to [email protected]

    If this helps, kindly click on agree.



    OMEN Laptop 15-en1037AX (Bitdefender Total Security) & Samsung Galaxy S22 Ultra (Bitdefender Mobile Security)

  • I've found the easiest way to install or reinstall (as I just did) Bitdefender Wallet for Mozilla Firefox or Chrome (not I.E.) is to open up Bitdefender Total Security / Privacy / Password Manager / Settings & install/reinstall Bitdefender Wallet extension from there. Saves having to search extension stores for it or Bitdefender support docs, although thanks to @Flexx this is where I found out how to do it..


  • Altaira_Jade
    edited December 2021

    Steve S, thanks. That worked for me.