Unable to connect to the server

edited February 2022 in General Topics

Getting a rather generic error message trying to install the BD agent on windows 10. I have no proxy or VPN and have tried the steps in the https://www.bitdefender.com/consumer/support/answer/17225/ article including changing the DNS. Still getting the same error message. Have also tried rebooting the machine and support chat was of no use.

Can someone please advise on how to get past this? Thanks.



  • Flexx
    Flexx Defender of the month mod
    edited May 2020

    Hi Member

    Since you have tried all the listed steps in above stated bitdefender link, I would like you to kindly drop an email to bitdefender support at [email protected] stating the solution you have already done as per the above stated bitdefender link. Response may be delayed due to less staff and covid19. Rest be assured, they will reply back asap.

    If this helps, kindly mark answer as agree/ accepted



    (Bitdefender beta tester 2019/ 2020)

    OMEN Laptop 15-en1037AX (Bitdefender Total Security) & Samsung Galaxy S22 Ultra (Bitdefender Mobile Security)

  • Yeah. I did that too.

  • Hello @chrisafp12 ,

    1. If you have any firewall, disable it
    2. Make sure Internet Explorer and MS Edge and working correctly and see whether you can access central.bitdefender.com

    In your case, installation was sucess, but you are unable to access the Bitdefender account and login, right?

  • I signed up through NETGEAR Armor. So it seems that site doesn't really apply. armor.netgear.com seems to be the one for those of us that signed up through netgear. So does that mean we cannot install the Bitdefender agent?

  • When I run the program, it says netgear and I login but then when it asks for profile and email address, you press "Allow" and then it just says that it cannot connect to the server almost immediately. So should be fine with netgear since that comes up on the sign in window. Just there is some problem from there that it seems other folks have had as well. And yes. I turned everything off to try to get it to install - which is a bit scary to do. Still no luck with it.

  • Ran TCPView on it and these are the two connections that get created but perhaps there is some problem there.

  • and one more port too - that static akamai one too opens up.

  • Flexx
    Flexx Defender of the month mod


    Since forum/ community provides limited support, it is requested to kindly drop an email to bitdefender support at [email protected] stating your query in brief so that they can address it as soon as possible.



    OMEN Laptop 15-en1037AX (Bitdefender Total Security) & Samsung Galaxy S22 Ultra (Bitdefender Mobile Security)

  • Yep. did that too. No response. But assuming will get something back on Monday.