Bitdefender Free: blocks all sites without proper certificate

Options
Ottawa
Ottawa
edited December 2020 in Update

Since update today (9:27 GMT) - maybe even since yesterday - Bitdefender Free blocks all sites without proper certificate (self signed). Using link 'I know...' doesn't work at all or only parts of site appear (both Firefox und Chrome).

I put the sites on Exclusion list, no change. Only after clearing browser cache it works.

Comments

  • Ottawa
    Ottawa
    edited December 2020
    Options

    Correction: clearing browser cache doesn't help, just turning off 'Protection Shield'. Better to use HTTP on my own sites that deactivating. Hope Bitdefender fixes this!

  • JimmyMack
    Options

    This is also affecting paid version when installed on a second device but only in chrome, bitdefender is trying to verify all ssl certificates back to a bitdefender CA root that ends with .0000000001. This is not happening on my laptop which is the primary bitdefender device. If I browse via MS edge on the laptop with the issue in Chrome there are no issues.

    Only moved to Bitdefender a few days ago and its my daughters new laptop which basically now will not allow use of Chrome which she needs for online schoolwork, this was the whole point of buying her the new laptop so I'm pretty fed up and annoyed.

  • Ottawa
    Ottawa
    edited December 2020
    Options

    Yes, once Bitdefender 'Protection Shield' is active, with HTTPS the certificate has to be valid or the root certificate is changed to Bitdefender's own root.

    Accepting 'the risk' leads to an empty or corrupted website - after about 30 seconds. Putting this trusted website on the Exception list (whitelist) makes no difference.

    Since the only solution is to deactivate 'Protection Shield', l'll habe to look for a different antivirus software :(

  • Ottawa
    Options

    I am now trying Kaspersky Cloud Free. Had the same problem first, but I was able to deactivate 'Extended-Validation-SSL-Zertifikate (EV-SSL)' checking. I didn't see this option in Bitdefender Free.

  • Pagani
    Options

    hello me too. im have same problem.

  • JimmyMack
    JimmyMack
    edited January 2021
    Options

    well what I found was that it affected sites with a valid SSL certificate and I can get to those sites in say MS Edge but for some reason Chrome thinks some random bitdefender certificate is the certificate for all sites I try to access after installing bitDefender.

    Weirdly this is only affecting the second device I installed bit defender on, and I have tried uninstalling and re installing both bit defender and chrome, made no difference.

    Since I have paid for this AV I have raised a support ticket also, so far just the usual ask for screenshots, and check notifications in bitDefender (which there are none) so I have sent those in.

  • I have FIXED my laptop`s 2018 Total Security blocking everything and my VPN never connecting problem. Deleted Bitdefender and ran 2018 removal tool and ran it as administrator and rebooted laptop. Reloaded Bitdefender but still would not access internet...? Had to go fishing through some Windows firewall settings and restore to default settings, dispite the warnings. THEN...Bitdefender finally loaded and my VPN loaded and works !

    7 hours of frustration...hope this helps someone.

  • I have FIXED my laptop`s 2018 Total Security blocking everything and my VPN never connecting problem. Deleted Bitdefender and ran 2018 removal tool and ran it as administrator and rebooted laptop. Reloaded Bitdefender but still would not access internet...? Had to go fishing through some Windows firewall settings and restore to default settings, dispite the warnings. THEN...Bitdefender finally loaded and my VPN loaded and works !

    7 hours of frustration...hope this helps someone.

  • I have FIXED my laptop`s 2018 Total Security blocking everything and my VPN never connecting problem. Deleted Bitdefender and ran 2018 removal tool and ran it as administrator and rebooted laptop. Reloaded Bitdefender but still would not access internet...? Had to go fishing through some Windows firewall settings and restore to default settings, dispite the warnings. THEN...Bitdefender finally loaded and my VPN loaded and works !

    7 hours of frustration...hope this helps someone.