Bitdefender blocks Time Machine back up with MacOS Monterey

Options

Hi everyone,

I've being using macOS Monterey for the last few days and I haven't had any problem untile a couple of hours ago.

Bitdefender has been blocking/preventing me from backup to my Time Machine server, with the following error message:

"An unauthorized app attempted to access your backups.

App: /System/Library/PrivateFrameworks/DiskImages2.framework/Versions/A/XPCServices/diskimagescontroller.xpc/Contents/MacOS/diskimagescontroller

We blocked the app to prevent it from altering the content of your backups.""


The problem seems to be related or at least similar to the one reported here: https://community.bitdefender.com/en/discussion/89355/bitdefender-prevents-time-machine-back-up-with-macos-monterey


So far I managed to make my Time Machine backup working by disabling the Time Machine Protection in inside Bitdefender configurations. But this is obviously a sub-optimal solution.

Has anyone being having the same problem?

Thanks for your help!

Comments

  • Update: I tried enabling Time Machine Protection again and everything seems to work just fine.

    In my specific case the issue seems to have been solved.

    I also noticed that there have been a few updates to the threats database, so it might be related to that.


    This post is also duplicated here: https://community.bitdefender.com/en/discussion/89400/bitdefender-blocks-time-machine-back-up-with-macos-monterey#latest

    Sorry for double posting, but in case that one can be closed too if no one else had the same problem.

  • Same here, BD is blocking Time Machine backups.

    Guys, I renewed the subscription to be protected, not to be blocked from backing up my computer. Fix this please.

  • Mike_BD
    Options

    Hello @JackTheDev and @DefendMePlease ,

    Thanks to the community input found here, we have working on a fix and soon will be releasing update 9.0.3.2. After update, please let us know if issue is persistent.

    Happy holidays,

    Mike

    Intel Core i7-7700 @ 3.60Ghz, 64GB DDR4 || Gigabyte nVIDIA GeForce® GTX 1070 G1 8GB || WD Blue NAND 500GB + 1TB

  • Just tried my first time machine backup to a new Western Digital 'My Cloud Home' device only to have Bit defender block it. Running Monterey as well. Please advise when there is a fix for this, it is getting a bit frustrating now as this has been ongoing since October. Thank-you.

  • I have the same issue and it remains there after upgrading to Bitdefender 9.0.3.3.

    I have already left one of my subscriptions expire because I find this issue completely unacceptable and I won't renew my other subscription if this issue isn't fixed soon.

  • Alexandru_BD
    Options

    Hello everyone and thank you for your input on this.

    Our developers are conducting an investigation and a fix will be deployed via an automatic update of Bitdefender.

    Stay safe.

    Premium Security & Bitdefender Endpoint Security Tools user