Unable To Distribute/Install Endpoint Via Jamf Pro. Any Help?

edited March 6 in Enterprise Security

Hello everyone,

We've had Endpoint Security on our Macs for about five years now and everything has worked with distribution/installation via Jamf Pro until late last year after we've updated to the latest package.

The Process looks as shown bellow with the error message. Does anyone know what could be wrong and/or what to do?

1. Executing Policy Antivirus - Bitdefender

2. Downloading antivirus_for_mac_arm.pkg...

3. Downloading https://euc1-jcds.services.jamfcloud.com//download/952aecdf92e54c788e0e69144d29572e/antivirus_for_ma......

4. Verifying package integrity...

5. Installing antivirus_for_mac_arm.pkg...

6. Installation failed. The installer reported: installer: Package name is Endpoint Security for Mac installer: Installing at base path /

installer: The install failed. (The installer encountered an error that prevented installation. Contact the software manufacturer and ask for assistance. An error occurred while running ****** from package "antivirus_for_mac_arm.pkg".)

7. Running command installer -pkg /Users/Shared/BitDefender_ARM/antivirus_for_mac_arm.pkg -target /...

8. Result of command:

installer: Error - the package path specified was invalid: ’/Users/Shared/BitDefender_ARM/antivirus_for_mac_arm.pkg'.


  • Gjoksi
    Gjoksi DEFENDER OF THE YEAR 2022 ✭✭✭✭✭


    Since you need help with business product, @Alex_Dr or @Andra_B (they both provide support for business products) could take a look here and help you with the issue.

    Also, you can always contact the Bitdefender business support:


  • Alex_Dr
    Alex_Dr Quality & Customer Experience Specialist BD Staff

    Hello @JonasR,

    Have you tried installing it using the steps in this link -> Install security agents - use cases (bitdefender.com) ? Please let me know how it goes.

    If it is still unable to install, strongly recommend contacting the Enterprise Support Team in this instance as extensive troubleshooting will need to be performed (gathering logs, uninstalling/reinstalling product, most likely)

    Awaiting your reply,

    Alex D.

  • Hello @Alex_Dr,

    Thanks for you information. We’ve done like this before and it has worked well until the end of last year. But I think I shell redo the whole process later on when I got time.

    I’ll send you a reply when done and it it still doesn’t work.



  • Alex_Dr
    Alex_Dr Quality & Customer Experience Specialist BD Staff

    Thank you for the quick reply @JonasR, I await your response for the new installation and, if there are, error messages or other warnings when installing.

    All the best,

    Alex D.

  • Hello again,

    I got some time over this afternoon :)

    I tried the SetupDownloader and got the following error when running the policy:

    Executing Policy Bitdefender downloader

    Downloading BDsetup.pkg...

    Downloading https://euc1-jcds.services.jamfcloud.com//download/952aecdf92e54c788e0e69144d29572e/BDsetup.pkg?token=b44bd2c7f2a64964a5408eea9e65b824mdy9wwuhbl7t8ju5ly5mlew8goaaqtrm...

    Verifying package integrity...

    Installing BDsetup.pkg...

    Successfully installed BDsetup.pkg.

    Running ****** BDsetup.sh...

    Script exit code: 127

    Script result: /Library/Application Support/JAMF/tmp/BDsetup.sh: line 1: Users/Shared/SetupDownloader.app/Contents/MacOS/SetupDownloader: No such file or directory