Stuck during scan

After upgrade os to 10.15.14 my Bitdefender has problem with scaning hd.

It stuck on random file from system/library folder. Also BDLdaemon has near 100% CPU usage.

Sometimes it stuck on usr/bin/uux file.

System restart does not solve problem. Do you have any similar issue?



  • I can't believe I've finally came across another human being that is experiencing the same issues as me. I have been searching the online forums but couldn't come across anything similar to what I have been dealing with for the past two days, ever since I upgraded to macOS 10.15.4. I'm so happy but also still very frustrated with this exact same issue.

    BDLdaemon has near 100% CPU usage and Bitdefender hasn't been able to complete a scan even once. Usually stuck on that same file. Restart doesn't help. I've also tried rebuilding the spotlight index, running first aid on my hd in safe mode etc. The only option left is to call customer support, which I've been trying to avoid. No other choice.

    I know this probably doesn't help but I'll post again if I end up finding anything that works.

  • I have the same problem. Has someone answered?

  • Hello @sb16 , @parsifal16 ,

    Please contact us at [email protected] so we can look into this. I'll need a few logs to further troubleshoot this situation, hence why I'd like to continue the communication via email.

  • I’m having the same exact issues and it’s really getting annoying. I also have Traffic Light enabled on Firefox and the Dashboard indicates that I do not and that I have to fix it (running around in circles on that one). The only thing that seems to work right is the quick scan.

  • Flexx

    Hi Member,

    Sorry for the inconvenience caused to you. Kindly make sure that you always create a new ticket regarding your issue. Because the solution which may work for others may not work for you or vice versa.

    @Alex D. is the staff of Bitdefender and as he said in the trail chat, kindly drop an email to bitdefender support at [email protected] regarding your query. The forum can only provide you with limited support.

    Hope this helps.



    (Bitdefender beta tester 2019/ 2020)

    Life happens, Coffee helps!

    Bitdefender Ultimate Security Plus (user)

  • Hi Zawaja. Were you ever able to get this solved?

  • Hello everyone,

    Our development team is currently looking into this issue. A fix will be delivered via automatic updates.

  • Same problem here. Scanning gets stuck on a random file (and not necessarily the same file each time) when I scan. I have rebooted the Mac and tried. It just gets stuck on another random file.

    macOS Catalina 10.15.5

    Date: 06/06/2020

  • nat0
    edited June 2020

    The files it gets stuck on are typically .doc or .docx files. Upon Re-scans, it doesn't necessarily get stuck on the same file, but it does seem to get stuck on another MS Word file. This 'getting stuck on Word files' did not occur ever before this.

  • Same is happening to me for both Full and Quick scans. On a MacBook Pro (mid-2015) running 10.15.4. Thank you for letting us know an update is pending.

  • Flexx

    All Members,

    @Alex D. is a part of bitdefender staff and as it is quoted that the development team is already aware of this and already working on this, releasing update takes time. So it is requested to kindly wait until you will receive updates automatically through your product.



    Life happens, Coffee helps!

    Bitdefender Ultimate Security Plus (user)

  • Having the same experience. Can't complete a quick and a full scan.

  • I'm a new user/purchaser of BitDefender and I'm encountering the same problem

  • I've just purchased Bitdefender today and I cannot complete a full scan without it getting stuck on random files. Any advice??

  • Same issue here, will Bitdefender post on this thread when a fix has been issued so I can try a full scan again? I'm installing on all our Macs at school but seem to be having this problem on only one machine.

  • Flexx
    edited June 2020

    Hi Member's

    Bitdefender staff may or may not reply back on this thread. As it has been quoted by the staff member (@Alex D.) in the above reply, the issue is currently in check with development team and as soon as a patch will be available, it will be released to respective bitdefender product through automatic update.

    Kindly refrain from posting in this thread again and again regarding the same issue which development team is already aware of. It will not be of any help.

    If you are curious to know about release date of patch, kindly drop an email to bitdefender support at [email protected] .

    Response may be delayed due to less staff and covid19. Rest be assured, they will reply back asap.



    (Bitdefender beta tester 2019/ 2020)

    Life happens, Coffee helps!

    Bitdefender Ultimate Security Plus (user)

  • I just bought this program yesterday, and it repeatedly gets stuck during a system scan of my iMac. I've tried a system scan almost a dozen times now, including reboots in between, and the program has yet to complete a scan. It has gotten stuck at different files and always in the range between 940,000 and 950,000 files scanned, which represents a very small percentage of the total files on the HD.

  • I too had the situation where the System Scan would get stuck (hang) before the scan was finished. Today I turned off "Preferences | Scan only new and modified files" and the System Scan completed successfully and found and removed a few viruses.

  • I had the same situation with scanning usr/bin/uux and 100% of used CPU

  • Hello everyone,

    The issue has been fixed in our latest update.

    Please open Antvirius for Mac and press Command + U while having the interface open on your screen. Wait for the update to complete, reboot the device and check if the situation persists.

  • I had the same issue. Called Customer Care on June 9th, before seeing this threat. They clearly were not aware. A day later I pointed Customer Care by email to this threat. They decided to ignore my tip. On June 11th I called them again and made them read the threat. Again, they were not aware, but promised to check internally and let me know once the issue was resolved. While still waiting for such confirmation three days after the issue had been fixed, I got an email from them today claiming they "haven't heard" from me and are closing the ticket.

    I am a long standing Bitdefender client, however am starting checking out the competition with a view to changing my antivirus provider with one who respects their clients. Clearly not Bitdefender's strength.

  • Can anyone else comment on Bitdefenders customer service regarding this issue. I've been a long time Webroot customer and am running into similar issues. Webroot has struggled to fix their product for over 7 months. They do not have a working Mac version but still push their subscription demo and new customers are told to call their customer service all the while they know what the problem is and play dumb.

  • Gabrielhn
    edited June 2020


    I've updated Bitdefender after June 13th, when the fix for this problem was supposedly launched, in my Mac but the issue still persists. It gets stuck during a full scan at /usr/bin/uux file and the BDLDeamon process is always near 100%.

    Any news about it after the fix of June 13th?

    Thank you for your attention.

  • Still fails on OS X 10.15.4 on June 23rd 2020 - not going to work for my macs. Back to FortiClient...

  • SNicker317
    edited June 2020

    Same Issue, I thought I was going to be the only one experiencing this... Glad to see that Bitdefender is aware of the issue. Although I am a little disheartened to see that this has been occurring to others since March. Just started happening to me a few days ago as far as I know.

    Hope it's fixed soon or I will have to remove it. My macBook runs very hot as it is and this isn't helping any, adds about 30 DegC to the operating temperature.

    I forgot to mention that I tried the Update suggestion, but it said I was already running the latest version.

    Also, any attempt to access the main screen just leads to a crash and even doing a force quit doesn't clear the screen or the spinning wheel... only a restart temporarily clears the issue, but a few minutes later it's back. Guess I'm going to end up removing it from my machine... If it lets me do that...

    Thanks in advance,

    Steve .

  • Hi @SNicker317

    I guess based off this you would recommend me waiting before switching to Bitdefender from Webroot :)

  • Let's just say this isn't the first time this has happened with regard to their updates, problem is they are slow/non-existant to let people know when these issues are fixed. Outside of these semi-yearly hiccups the product works great... but I am getting close to renewal time and experiencing some second thoughts myself. I am although, gonna give them the benefit of the doubt as possibly they are short handed at the moment with the Covid issue. I guess that's one kind of virus even they can't remove...😡

  • Same problem here...drives me crazy!!!

    Is there no temporary workaround for this problem until they fix it in an update?

  • Ya I hear you. I've been a long time Webroot customer and their product hasn't worked properly since the end of 2019 (6 months). They just released a version a week or so ago that seems to work now. The thing I struggled with them was that there was zero feedback from the company as to the issues they were having. They would just tell everyone on their community board to call support. Anyone that called ended up waiting an hr or more for a tech support person to remote into their machine play around and solve nothing. They even pushed their product (on many social media platforms with free 30 day demos) over the last 4 months knowing that it wouldn't even install or run properly. I'm not sure I want to renew with them but my subscription is up in a month and their product now works.

    From my research Bitdefender is at the top or near the top with regards to defense but I don't want to jump out of the frying pan into the fire if their product still isn't working on the latest OSx version.

  • I am also having the stuck on a file during a full scan issue. It's been going on for quite awhile. It will be nice when it is fixed, after all, I did pay for the program to work, not to hang up during a scan.

  • Same problem here.

    After excluding CodeMeter from being scanned, I could do a full quickscan, an then even a fullscan without freezing my desktop. This is Win10 Pro Workstation here (hp zBook 17g5, 6cores, running preinstalled hp SureClick)

    Maybe this can help you

  • Same issue gets stuck between 940,000 and 950,000 files. First couple of times on pdf files, 3rd time a different file type. New User installed today on my iMac and tried to do first full system scan.....What is going on?

  • Another user with this stuck issue on MAC 10.15.6 Had the same problem several several months ago and opened a ticket. There were some messages back and forth but no 'fixed it' message. Problem went away for a while but now its back.

  • Having the same exact issue right now. I suppose I will go ahead and uninstall and ask for my money back. The CPU usage is unsustainable.

  • My renew date is soon and I will not renew unless this problem is fixed. Bdldaemon was using 100% of CPU for two days and it was obviously stocked. Full scan sticks at random file. This is not a product which should be on the market. Fixing problems takes far too long.

  • I uninstalled Bitdefender completely which was a but complicated job to do. Uninstall didn't work and "manual Method 1" neither. Then I reinstalled, updated and system scanned. And now it seems to work properly. If only one could trust this status will stay.

  • Today I got a reply to my ticket and indeed the un/re-installing is the recommended fix:

    Hello Hannu,

    Thank you for your reply.

    The situation you have encountered is usually being caused by an outdated Bitdefender Agent present on your device.

    In order to completely remove/uninstall Bitdefender Antivirus for Mac, please follow the steps provided in the article below:

    Afterward, download and install, using the latest kit following the steps in the link below:

    Let me know how everything goes and if I can assist you with anything else.

    Have a great day ahead!

    Kind Regards,

    Gabriel P.

    Customer Support Engineer

  • FYI: I reinstalled today (19-aug-2020), did a full scan and that scan has been stuck on a file for over two hours. Now, assuming the file shown is the one bitdefender is actually processing, the program has spent over two hours analyzing a few hundred bytes - the file's size.

  • I had what looks like the same issue. I ran a full scan but had to cancel before completion. From that point forward BD showed itself to be in "scanning new files" mode and BDLDaemon appeared to be spinning.

    The remedy was to do a complete uninstall and then a fresh install. Since that time I haven't re-tried to run a full scan for fear I'll encounter the same bug -- which is kinda a big limitation for a virus scanner -- but I've been running for a couple weeks now without issue. At some point when I have more time I'll retry the full scan.

  • Hi,

    Pretty desperate here, been running my first scan on bitdefender free and I'm nearly at 21 hours and it hasn't finished yet is this normal?

    All other antivirus protection has been removed. Sorry if I posted this in the wrong area but I did do a search and this is the best I could find.

    Cheers Johan

  • Ok finished scan two threats detected that it says I have to manually remove, next step look for answer on forum.

  • Flexx

    Hi Member's,

    Kindly drop an email to bitdefender support at [email protected] regarding your query. The forum can only provide you with limited support. The support team can share your issue internally with development team and also get you an update for the same.

    Hope this helps.



    (Bitdefender beta tester 2019/ 2020)

    Life happens, Coffee helps!

    Bitdefender Ultimate Security Plus (user)

  • I too have the same problem now. Stuck on /usr/bin/uux

  • Here to report the same issue as those above. Removing and reinstalling has not fixed the issue; in fact it appears to have exacerbated this issue, at least on my device. While I recognize technical problems arise, it is entirely unacceptable the issue(s) persist. This isn't freeware. So far the service I have paid for is doing more harm to my system than the malware it is intended to prevent.

  • Omid
    edited October 2020


  • I have experienced a new problem ..... This morning I ran a “Quick Scan” without issues. Then I ran a “System Scan” and after about 450k files, it seemed to stop.

    I shut down my Macbook Pro (15-inch, 2018; running macOS Catalina ver. 10.15.7), restarted, ensured that my BitDefender was updated, then reran the “Quick Scan” only to have it stop. When Canceled that function, I ran a System Scan and it stopped on “/usr/bin/uux” this time.

    OMG, this is so frustrating. What is wrong with BitDefender?

    I need to know my system is protected and I know this by running scans.

    Is this software obsolete now? Do I need to find a different way to ensure our office Macs are protected?

    I need a reply to this quickly.

  • This is still happening to me, and I do have the most up-to-date version. Ugh!! It uses up so much of my CPU the fan is always running too.

  • Flexx
    edited November 2020

    Kindly drop an email to bitdefender support at [email protected] regarding your query. The forum can only provide you with limited support. The support team can share your issue internally with development team and also get you an update for the same.



    (Bitdefender beta tester 2019/ 2020)

    Life happens, Coffee helps!

    Bitdefender Ultimate Security Plus (user)

  • I'm using the free version to test after which I'd intended to buy the paid version. But this is ridiculous. Scan is looping on the files in my outlook archive folder. It's been over 90 minutes now.

  • Just purchased. Having this problem on my very first scan attempt. Mac OS 10.15.7 (19H114). Gets stuck on a file in:

    Users/UserName/Applicati...ts/Resources/SamsungPortableSSDMon (disk)

    1793 Files scanned

    1 Detected

    0 Resolved

    Please advise.