Total Security 2021 (Build 25) Update Causes "Don't Have Permission to Save to This Location" Error


Immediately after the TS 2021 update restart on my Win 8.1 PC, I could no longer save files to OneDrive. The error states, "you don't have permission to save to this location." However, when I checked the folder permissions, my account still has its admin permission and is the owner of the folder.

I have not found anything in this new Bitdefender version I can pinpoint as the cause, and turning off all the prevention modules did not fix the problem.

I submitted a support ticket hours ago, but haven't received a response yet. Thanks in advance to anyone here who has a suggestion how to fix it.


  • Flexx

    Hi Member,

    The support team replies back in maximum of 72 hours excluding saturday & sunday (or sometimes maybe inclusive of saturday & sunday). Your issue can be resolved by the support team only. The support team receives large number of request and they get answered in orderly manner. Kindly wait for sometime. The support team will definitely revert back to you.



    (Bitdefender beta tester 2019/ 2020)

    Life happens, Coffee helps!

    Show your Attitude, when you reach that Altitude!

    Bitdefender Ultimate Security Plus (user)

  • UPDATE: Other users are also reporting the same Bitdefender 2021 created permission issue. See these posts on

  • aramanja

    A friend was also having this problem and we fixed it by doing the following:

    1. Uninstall all Bitdefender components and restart computer
    2. Go into My Devices on Bitdefender Central and remove the computer from the list of devices
    3. In Bitdefender Central, click on Install Protection to reinstall Bitdefender. (This should reinstall Total Security 2021)

    Not sure whether it made a difference, but we made sure to not have any other programs (like Outlook) open on the computer while doing this.

    Windows 10 FYI.

  • UPDATE #2: I found that re-installing BD is only a temporary fix.

    After removing all traces of BD from my PC and deleting that device from BD Central, I reinstalled BD 2020. which updated to 2021 automatically. Removing BD immediately fixed the permission issue I was having, but it only held for two days when the same problem came back again without warning or obvious cause (silent update?).

    Today I removed and reinstalled BD again, but sadly, that did not fix the issue this time.

    At this point, I am very disappointed in BD 2021, which seems to me to be quite unruly and rather insidious compaired to earlier BD versions. Support takes forever (days) to respond and hasn't been very helpful so far. So, I will most likely be forced to find a new AV product.

  • MvdS
    edited October 2020


    I suppose it has to do with 'Safe Files" in the previous Version. Now you can't find it in the interface. Somehow the directory 'Documenten' is protected. It has to be a bug. I did copy all the files from the drive where the directory 'Documenten' are to a portable drive. After that I did format the drive and copied everything back. Then I could write to that map again. But now after a week or so, the same problem again!!! On two PC's.

    The Helpdesk in Amsterdam is until now not a good help, they did not answer questions, did not keep promises. Shall try Calling tomorrow again 😥.

  • MvdS


    Solved the problem myself. The new version of BitDefender did not remove everything. To solve the problem I did the following:

    1. Download the removal tool at bitdefender.
    2. Uninstall BD. The program responds probably that it could not remove everything and you should call the helpdesk. Do'nt call the helpdesk they are of no use at all.
    3. Restart the PC in safe mode. use from Settings when you have Windows 10.
    4. Remove all files from BD in C:\Program Files and in C:\Program Data. When you are not in safe mode, you can not remove these files because there is something busy.
    5. Restart the PC, then you ar in normal mode again.
    6. Use CCleaner to clean the registry. You will find some settings from BD
    7. Reinstall the program with Bitdefender Central

    After point 5, I did have full rights on the folder Documents again.

    Good luck all.