my bdservicehost uses too much of my cpu and memory all the time, how can i fix it?

ritwik_zzritwik_zz
edited May 2020 in General

Currently none scans are running and its still eating up my cpu, and its every time . my specs are i5 -8300h @2.30gh with 8gb ram


Answers

  • FlexxFlexx ✭✭✭✭
    edited May 2020

    Hi Member,

    This issue is very common with most of the people who use bitdefender. But, this seems really weird as per the specification of your PC. Bitdefender should have run smoothly in your case.

    System requirements for bitdefender are as below :


    Try the below solutions :

    1) Kindly go forward and uninstall the bitdefender product via bitdefender product removal tool :

    https://www.bitdefender.com/site/view/uninstall_consumer_paid.html (select uninstall tool as per your version)

    2) Kindly remove your windows device from bitdefender central account :

    https://www.bitdefender.com/consumer/support/answer/2795/

    3) Restart your PC

    4) Open run command (windows icon + r) & delete temporary files from below 3 folders one by one :

    • type temp, delete all files in the folder
    • type %temp%, delete all files in folder
    • type prefetch, delete all files in folder

    5) Now, reinstall the bitdefender product again (either from central or directly from their website)

    6) Restart the PC & check if the issue persists.

    If the issue persists, generate bitdefender logs (https://www.bitdefender.com/consumer/support/answer/1922/) & kindly drop an email to bitdefender support at [email protected] .Briefly explain them your issue and also attach the bitdefender logs in the same mail. Also attach the new screenshot from task manager. Wait for their response.

    Response may be delayed due to less staff and covid19. Rest be assured, they will reply back asap.

    If this helps, kindly mark answer as agree/ accepted

    Regards

    Flex

    (Bitdefender beta tester 2019/ 2020)

  • FlexxFlexx ✭✭✭✭

    @ritwik_zz

    If your issue has been resolved, kindly mark answer as agree/ accepted

    Regards

    Flex

  • Has this issue ever been fixed by Bitdefender? I've been searching tonight and find multiple threads on multiple sites about this issue that has apparently been occurring for at least 5 months and the only responses seem to be "we know it's an issue".

    I even turned off Bitdefender Shield but the Bitdefender Virus Shield bdservicehost is still taking up 90+% of the cpu (and no scan is running).

    I never had this issue with TS 2020. It's only been since "upgrading" to 2021.

    It is absurd to ask people to go through the procedure above for what is clearly a known bug in Bitdefender that has still not been fixed.

    If it keeps happening, I will be stopping with step 1 above (uninstall Bitdefender).

Sign In or Register to comment.