my bdservicehost uses too much of my cpu and memory all the time, how can i fix it?

ritwik_zzritwik_zz
edited May 2020 in General

Currently none scans are running and its still eating up my cpu, and its every time . my specs are i5 -8300h @2.30gh with 8gb ram


Answers

  • FlexxFlexx ✭✭✭✭
    edited May 2020

    Hi Member,

    This issue is very common with most of the people who use bitdefender. But, this seems really weird as per the specification of your PC. Bitdefender should have run smoothly in your case.

    System requirements for bitdefender are as below :


    Try the below solutions :

    1) Kindly go forward and uninstall the bitdefender product via bitdefender product removal tool :

    https://www.bitdefender.com/site/view/uninstall_consumer_paid.html (select uninstall tool as per your version)

    2) Kindly remove your windows device from bitdefender central account :

    https://www.bitdefender.com/consumer/support/answer/2795/

    3) Restart your PC

    4) Open run command (windows icon + r) & delete temporary files from below 3 folders one by one :

    • type temp, delete all files in the folder
    • type %temp%, delete all files in folder
    • type prefetch, delete all files in folder

    5) Now, reinstall the bitdefender product again (either from central or directly from their website)

    6) Restart the PC & check if the issue persists.

    If the issue persists, generate bitdefender logs (https://www.bitdefender.com/consumer/support/answer/1922/) & kindly drop an email to bitdefender support at [email protected] .Briefly explain them your issue and also attach the bitdefender logs in the same mail. Also attach the new screenshot from task manager. Wait for their response.

    Response may be delayed due to less staff and covid19. Rest be assured, they will reply back asap.

    If this helps, kindly mark answer as agree/ accepted

    Regards

    Flex

    (Bitdefender beta tester 2019/ 2020)

  • FlexxFlexx ✭✭✭✭

    @ritwik_zz

    If your issue has been resolved, kindly mark answer as agree/ accepted

    Regards

    Flex

  • Has this issue ever been fixed by Bitdefender? I've been searching tonight and find multiple threads on multiple sites about this issue that has apparently been occurring for at least 5 months and the only responses seem to be "we know it's an issue".

    I even turned off Bitdefender Shield but the Bitdefender Virus Shield bdservicehost is still taking up 90+% of the cpu (and no scan is running).

    I never had this issue with TS 2020. It's only been since "upgrading" to 2021.

    It is absurd to ask people to go through the procedure above for what is clearly a known bug in Bitdefender that has still not been fixed.

    If it keeps happening, I will be stopping with step 1 above (uninstall Bitdefender).

  • Chuck_IVChuck_IV ✭✭
    edited March 11

    Just posted about this on another thread. BD has been taking 16% of CPU for HOURS now today(been going on for quite a while beyond today) and upping my CPU temps by 15 degrees, while continually thrashing my hard drive. This occurs sporadically but often and for LONG periods. When it's not happening, BD takes less than 1% of my CPU.

    I tried Flexx's suggestion above but nope, as soon as I reinstall it, off we go again. Only way I was able to stop it was to turn OFF the AV Real Time Protection and then REBOOT. After the reboot, things would go back to normal. But of course this defeats the purpose of this software, so I've uninstalled BD for the time being and am test driving something else as I cannot let this go on. This PC is an i9 10900 so anything should NOT be going on for HOURS. This type thing put a hurting on my laptop.

    Based on the longevity of these threads, BD doesn't seem interested in fixing this.

    EDIT

    So I just checked my daughter's PC and laptop and BOTH are slow as molasses because on her PC, BD is taking OVER 50% of her CPU and similar on her laptop with this SAME ISSUE.

    Gonna have to uninstall it there too as she uses her laptop for school.

    It wasn't like this in late JAN/early FEB. One of your recent updates has caused this. PLEASE ROLL IT BACK until you can fix this issue.

  • Chuck_IVChuck_IV ✭✭
    edited March 11

    Just posted about this on another thread. It has NOT been fixed and is getting worse. On my top of the line PC with an i9 10900, BD Total Security is taking over 16% of the CPU, causing my hard drive to go crazy and raising my CPU temps by over 15 degrees for HOURS ON END. Then it will magically stop for a little while, then start up again. On my daughter's PC AND Laptop, BD is using OVER 50% of her CPU.

    ONLY way to get it to stop is to disable the AV portion of it and reboot. But of course that defeats the purpose of this product. I have tried Flexx's suggestion up top but it doesn't help. As soon as I reinstall it, off we go again with the high usage. The 2020 version never had this issue, only the "new" 2021 version does.

    I have no choice but to uninstall it and move on, until I hear this is fixed, as my daughter uses her machine for school and she can hardly do anything with the CPU usuage that high.

    Really seems they either don;t know how to fix it or aren't concerned about it,.

  • Flexx's suggestion worked for the CPU, memory usage still the same, but I don't think its an issue now.

    Another issue is whenever I am gaming, the bdservicehost disrupts my ping a lot. I can't even turn it off for some time. Please do something else I'm not buying this again.

  • Having same issue. Will have to go with another product if a resolution is not found quickly.

  • FlexxFlexx ✭✭✭✭

    Generate bitdefender logs (https://www.bitdefender.com/consumer/support/answer/1922/) & kindly drop an email to bitdefender support at [email protected] .Briefly explain them your issue and also attach the bitdefender logs in the same mail. Also attach the screenshot from task manager. Wait for their response.

    Response may be delayed due to less staff and covid19.

    Regards

    Flex

    (Bitdefender beta tester 2019/ 2020)

  • GladeGlade
    edited May 20
    I tweaked a few settings in bitdefender a month back and after a couple days maybe I also stated having same issue, I had 8gb ram but overtime it would start eating my ram making my PC sluggish. Now after few tweaks here and there when I disabled "silent update" Under "Settings - Update" Tab and Restart PC, I didn't face the issue again, though after every few hours I get update notification, but its better than having my PC slowed down altogether. Don't if it was just me or not but Hope it helps others...
Sign In or Register to comment.