Kindly be advised we cannot cancel subscriptions or issue refunds on the forum.
You may cancel your Bitdefender subscription from Bitdefender Central or by contacting Customer Support at:

Thank you for your understanding.

Bitdefender Security installation is launched, but does not install

Eximius Sir, MSc., MBA
edited May 2023 in Install & Updates

I have alreday installed it OK in 3 devices. Last one is a W10 PC (legal), i7 sufficient disk space.

I have tried several times the installation (in Administrator role), but the furthest it goes is to ask me authorize the launch of the downloaded file.

And it is my best and key domestic device. No proxy.

Please provide me advice!!!


  • Alexandru_BD
    Alexandru_BD admin
    edited May 2023

    Hello @Eximius and welcome to the Community!

    There are insufficient details for us to understand what is happening there. What happens after you are asked to authorize the launch? Do you get any error message at all, or does the installation process end there? Do you have any other security solutions installed on that device? Did you previously have Bitdefender installed on that computer? Are you logged on to Windows with an Administrator account or with a standard (restricted) account?

    If this error message is received during the Bitdefender installation "Some installation files are corrupted" OR "There was a problem downloading one of the installation files", please make sure that an Internet connection is available and try again.

    But we are just making assumptions here, we can't know for sure without further information. I would recommend contacting the Support engineers, so they can have a closer look and guide you through the installation process.

    You can get in touch with our engineers by choosing one of the contact channels available here:

    Let us know how it goes.


    Premium Security & Bitdefender Endpoint Security Tools user

  • Eximius
    Eximius Sir, MSc., MBA

    Thanks, Alexandru_BD,

    I will try to answer your questions:

    1) the installation process the screen I attached before.

    2) No other security soluctions installed.

    3) Did you previously have Bitdefender installed on that computer? *** Yes, the Free version ***

    4) Yes, I mentioned... "the installation (in Administrator role)"

    5) "Some installation files are corrupted" OR "There was a problem downloading one of the installation files": NO

    Guessing out, I realized that the problem might be due to previous versions installed files, so I tried deleting "Bifdefender client" app (only one shown), but it did not let me, as it warned that I had to previosuly delete the "Bitdefender security" app,...which was not displayed in the application list of Windows apps. So...stranded...

    But, luckly, after switching on the PC one morning, the downloading of the SW restarted and showed the screen with the big circumference (seen before in the other devices). Downloaded OK, installed OK and now it works fine.

    I did not find such problem in the 3 other devices, the reason might be that thet did not have a previous version of Bitdefender installed.

    I hope this could help to other stranded I was surprised to find me in this situation with a leadind software provider. Flashed me back to 7-8 years ago!!!

    Kind regards to all!!!